1. Hello Guest, if you are having any kind of issues with the site, please email Admin@BrokeAuto.com and let me know what is going on. I will do what I can to get the issue resolved quickly. This site is still a work in progress and there is a lot to be done so any info you can give me will really help. Thank you!
    Dismiss Notice
  2. I have disabled email verification due to some email issues. Now, just fill out your info and your done. I have also gotten rid of the reCaptcha and I'm now doing a noCaptcha where you just click a check box. Super simple and faster than ever! Please let us know if you have any issues or need to be verified. Thanks!
    Dismiss Notice

Mopar oil sensor

Discussion in 'Engine' started by murankar, Jul 16, 2014.

  1. murankar

    murankar Member

    Joined:
    Feb 8, 2014
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    I think my oil sensor is going bad. The oil light came on this morning. Got to work turned off the van and restarted and the light was out. This has happened in the past thought it was the oil but with new oil its still doing it. Any ideas?

    Sent from my LG-E980 using Forum Runner
     
  2. Tony

    Tony Administrator Staff Member

    Joined:
    Feb 4, 2012
    Messages:
    2,100
    Likes Received:
    1
    Trophy Points:
    38
    There should be two different sensors for the oil. One is for level, and the other is for pressure. If you are losing oil pressure, according to your idiot light or gauge, then you need to hook up a mechanical gauge to verify you have pressure. or just replace the sending unit. If this is the level sensor, screw it and just check your oil level lmao. That is what I do. I unplug mine....
     
  3. murankar

    murankar Member

    Joined:
    Feb 8, 2014
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Since the oil is still full i am thinking it could be pressure. As for fixing might be after i get home. I am going to keep on top of checking levels during my trip home to be safe.

    Sent from my LG-E980 using Forum Runner
     

Share This Page